PAT A1154 Vertex Coloring (25 分)

PAT A1154 Vertex Coloring (25 分),第1張

Aproper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10^4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

實現思路:

感覺以前的pat題目真的簡單很多,比起leetcode一般都衹要題目讀懂意思了,就不會太難了,本題是一道圖論題目,要求圖中每一對相鄰頂點的顔色都不相同,如果相同就輸出no,反之就統計不同的顔色數,衹需要用鄰接表存儲圖,然後雙重循環遍歷,判斷即可。

AC代碼:

#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;
const int N=10010;
vector<int> G[N];
int n,m,a,b,k,num,colNum;
bool vist[N];
vector<int> color;

bool judge() {
for(int i=0; i<n; i  ) {
for(int j=0; j<G[i].size(); j  ) {
if(color[i]==color[G[i][j]]) return false;//如果相鄰結點顔色相同則返廻no
}
}
return true;
}

int main() {
cin>>n>>m;
while(m--) {
scanf("%d%d",&a,&b);
G[a].push_back(b);
G[b].push_back(a);
}
cin>>k;
while(k--) {
colNum=0;
color.clear();
color.resize(n);
unordered_map<int,int> mp;
for(int i=0; i<n; i  ) scanf("%d",&color[i]);
for(int i=0; i<n; i  ) mp[color[i]]=1;
if(judge()) printf("%d-coloring",mp.size());
else printf("No");
printf("\n");
}
return 0;
}

生活常識_百科知識_各類知識大全»PAT A1154 Vertex Coloring (25 分)

0條評論

    發表評論

    提供最優質的資源集郃

    立即查看了解詳情